« Back to All Topics
Mission 49
Mission 49
Mission 49
Hi! I'm wondering if anyone has been having trouble with Mission 49? I'm stuck after I lose the iron key in 7c. According to Larkinor Guide in 6c you get teleported either to 1a (in which case you get the iron key again after fighting the monster and can continue the mission) OR 4c (no access to the iron key by any means), but I've repeated the mission more than 10 times and each time I only get teleported to 1a, so I'm effectively stuck. Do I just keep repeating hoping at some point I get lucky and teleport to the right square? I have a higher-level character which has completed this mission before but did not have this problem....
Thank you!
I'm on mission 43 so I can't help you. But if I manage to make it to mission 49 before someone helps you or you figure it out then I will try to help.

I know my reply isn't very helpful but I just wanted to assure you that people have seen your post and I assume haven't replied because they cannot help. Good luck!
hi! that's very kind of you. Thank you! Good luck and have fun playing!
Hello! Wondering if anyone can help. My character has advanced a few levels since then but I still haven't been able to complete the mission because of the teleport issue...I've tried this mission 30+ times and each time just get teleported to the square with the young microdragons (which essentially means the mission cannot be finished) but never the pukipu square needed to proceed. It's incredibly frustrating to be missing out on attributable points from mission mushrooms. This must be a bug of some sort? I know I have completed this mission with zero issue before with another character...
Have you tried following the mission map on Larkinorguide . com?
Yes. I've used the guide to complete the exact same mission with another character so I know for sure I'm not doing the mission wrong. There is no way to avoid losing the iron key in 7C and the only way to proceed is to get teleported in 6C to 1A where you can get another iron key. The problem is that in 6C you get randomly teleported to 1A (the desired outcome) OR 4C (no way to complete the mission), and I've tried 30+ times and every single time I only get teleported to 4C.