« Back to All Topics
erratic weight control
Posted in 
erratic weight control
Posted in 
erratic weight control
The weight control has become glitchy and I cant seem to do anything about it. It has ruined my game. It is just not fun anymore which is a shame because I love this game.

The power bar climbs at an unpredictable rate and is jumpy. In just trying to set a button weight on the stone, the meter will stop way early or way late.

I have done everything I can think of. I have rebooted my cable modem (20Mbs), rebooted the computer, changed batteries in the mouse, used a wired mouse and cleared my internet data. 

Please help, I am sick of trying skin by a hogline guard only to come off underweight, which no amount of sweeping will fix. Yesterday I gave up a 6 point end with the hammer. My hammer came off with a takeout weight when all i needed was an underweight shot that I could sweep to the button. It blew through knocking my stone that was holding my opponent to 1. 
Using a Mac

Just tried in different browsers. 

Safari (which I had been using) is best
Firefox is bad on every shot
Chrome is garbage, everything goes to a full takeout
mettlepig i think it varies i use chrome on a laptop and i have no problems setting my shots.maybe just a bad period or something.
I think it's a Mac & Java issue because I experience the same problem when I play the game on my Mac. I wasn't able to resolve it so now I only play the game on PC.
Java 7u60 update was released on May 28, maybe that is the change you noticed, since the game itself hasn't been changed for a while now.
This Java update was out-of-schedule, so they must have found something really important to fix asap...
You may want to give a try to Java 8 though, if it provides better performance.
(Or you can downgrade back to 7u55 and disable automatic upgrading until Curling gets converted to HTML5 too)

Thanks for the great responses. I will check my Java version and see how it goes.

I did manage to boot to a new user profile prohibiting software other than safari and java and that seemed to clear up the problem. The meter climbed much smoother and surprisingly slow. It was hard to be patient and let it climb to button weight. It tells me I have been living with the problem longer than I have noticed.

This causes me to suspect background processes, spyware or malware. Updates and scans in progress soon.
Problem is caused by some silly games my kids that stay resident and communicate game data in the background.

No malware or spyware found. 

Notes on Java. Mac provides its own versions based on 6 or 7 dependent on version of OSX. 8 not there yet. OSX 10.6 (mine) and older use a 6 version. As of now not causing problems.

Remedy is to create a guest profile that deletes all data on logout, and play in a clean OS environment. ( no background processes )

Thank you.
i had those same issues but on a pc not a mac, background programs where causing it. but when i finally resolved the issues I was much better player for not having to try to time the power with it different almost every shot, glad to hear you fixed it